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1.0 - Introduction: 

AD Query allows quick and easy auditing of any user or computer object within Active Directory, and unlike the 

standard Users and Computers MMC, AD Query shows all schema, LDAP and Exchange mail-enabled attributes 

associated with the object. 

With AD Query, there is no need to poke around in the schema, LDAP or Exchange MMC, or use scripts to convert 

schema data to something humanly readable.  

AD Query is 3 tools in one and a total time saver for the busy System Administrator.  The perfect companion tool 

to go along with Password Reminder PRO
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Features: 

• Uses data straight from Active Directory Schema and presents all data in human-readable format  

• Lightning-fast query of any user or computer AD object  

• Shows primary SMTP email address, all email alias (proxy) addresses, password last set date, account 

expiration date, and more  

• Shows all listed SPN's for computer / server objects, including DC's  

• Completely shows all hidden Schema user / computer object attributes in a single, easy to read display 

and eliminates need to use multiple tools like ADSI Edit or an Exchange-enabled MM

• Read-only software. Look up Schema data without fear of breaking something  

• Runs on any domain-connected Windows workstation or server  

• Stand-alone executable - Does not require a service or complex installation  

• User-friendly UI, no coding or schema configuration required  

• Runs under credentials of logged-on user (must be local admin)  

• Integrated search history buffer and export of search data to xml file  

• FREE xml-viewer available on our website support page. View your exports in a friendly neat format  

• API interface for quick searches directly in Password Reminder PRO! Click a user in Password Reminder 

PRO's Report Console and auto-launch the search in AD Query! *Feature requires version 1.4 of Password 

Reminder PRO and version 1.3 of AD Query to be installed on the same computer  

• Run AD Query searches from a command prompt or call from a batch file / script  

AD Query is designed for maximum compatibility with Windows 2000 / 2003 / R2 and Exchange 2000 / 2003 / 

2007 and converts all 'binary' and 'tick string' values to a user-readable form

 

 

 

 



1.1 - How AD Query Works 

AD Query is a 3-in-1 search and reporting tool for user and computer objects within Active Directory. It's sole 

purpose is to output all real-time Schema / AD / Exchange attributes for a specified AD object in an easy-to-read 

screen.  

AD Query looks deep within the AD Schema and reveals all object attributes; if it is there, you'll see it. Normally, 

you would need to open two or three Microsoft admin tools to accomplish the same task, especially when looking 

for mail-enabled or Kerberos object attributes

AD Query is invaluable for quickly reviewing an object to determine if problems exist or information is correct. All 

of the report view results are exportable via simple copy / paste
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1.2  - Installation Requirements 

Installation and use of AD Query requires the following: 

- Microsoft Windows XP, Server 2000 (min SP3) or Server 2003 

- Microsoft Windows Active Directory 2000 or 2003 Domain 

- Microsoft .NET Framework v1.1 and SP1 

- Domain account with sufficient privileges to read from your Domain Controller’s AD and LDAP 

- Local Administrator privileges on the computer where you will be installing AD Query (requires admin rights to 

install) 

- Valid license key for your Active Directory domain that holds user accounts. To obtain a fee key register an 

account on our website. 

 

2.0 - Software Installation and Setup 

Log on to the server or workstation that will host the AD Query program. You must use an account that has local 

admin privileges as the software writes to the HKLM portion of the computer registry.  

Run the installer, follow the prompts, click Finish to exit the installer.  

 

2.1 - Inserting your License Key 

AD Query will not function without a valid license key specifically issues for your domain, and will not perform 

searches in domains other than the one specified at time of registration. If you will use AD Query in different 

domain forests, you can easily create a key for the other domains from within our we

You should have created a free license key from within your secure login page on our website. You will be unable 

to download AD Query until you signup for an account on our website and create a license key for your domain

If you did not receive the verification / account activation email following signup on our site, and cannot access 

the links in your customer page to create a license key, contact Sales or Support immediately through the Contact 

Us page. We'll help you out!  

Launch AD Query from the Start Menu program group (SysOp Tools > AD Query) or desktop shortcut. 

At the top left of the admin screen click File > Register and you will see a box pop up to insert your license key.  

Copy your AD Query key string from your email or personal site login page and paste it here. Click Save. The 

http://www.sysoptools.com/contact.aspx
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software will detect your key and unlock for use in your specific domain.  

The word 'Unregistered' should now change to 'Search Domain'. 

If you do not see the correct status, exit and then re-launch the program, and double check to make sure you 

inserted the entire license key string.  

 

2.2 - Selecting and Changing your LDAP Search Domain  

AD Query will search the top-level domain (company.com) and also has ability to query sub-domains 

(sub.company.com).  

After installing your key, AD Query is set by default to search the LDAP domain that was specified at time of 

license key creation (the domain info is contained in the key you created). Before you can perform object searche

on a sub-domain, you must tell AD Query the name of the sub-doma

If you created a key for a child domain only (child.foo.com), you cannot upward-search the parent foo.com. We 

recommend that you only create keys for the parent root domain.  

 

Open AD Query  

Click Search > Change Domain and an input box will appear.  

Type the name of your sub-domain and click Change.  

 

Now you have set your search to look only at objects contained in the sub domain of the parent. To change back 

to the parent domain or to a different sub-domain, repeat the above process
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3.0 - Software Use and General Overview 

 

3.1 - General Use  

Performing a User or Computer Object Search 

If you have an extremely large amount of objects in AD or are querying a sub-domain across a WAN link, please 

allow AD Query some time to search and capture data before displaying results. In large environments across a 

WAN it can take a couple of minutes. 

If AD Query is unable to contact a DC for a specified sub-domain, or is unable to locate the object name when 

performing a search it will not return any results. 

Open the AD Query program 

Insert your license key if you have not done so already (File > Register)  

Once you insert your key the domain used to generate the key will show as 'Searching: domain.com' in the main 

program area.  

Select the type of domain object to query via the drop-down list (User or Computer)  

Type the exact name of the object  

For user objects, this will be the SAMAccountName or NT Account name, which is the username portion of the 

domain\username login. 

For computer objects, use the CN name (or netbios name) of the object  



Click 'Fetch Data', wait for results to display in the main portion of the console 

 

TIP: 

If you wish to query a child of the root domain, click Search > Change Domain and type the FQDN of your child 

domain. You will see the child domain display in the 'Searching:' area.  

 

AD Query does not perform "wildcard" searches or partial name searches. If you receive an 'object not found' 

popup, either the object does not exist or you have not input the correct object name.  

Exporting View Window Results 

AD Query has the ability to capture and export search results to an xml file. To export your search data, run an 

object search. When the data displays in the main view area go to File > Export.  

An object export data xml file will be created in the Program Files/SysOp Tools/AD Query folder. 

 

You may view the xml file in structured table format with our FREE xml viewer, which is downloadable from our 

website support page  

 

TIP: 

AD Query buffers your search results in memory. You may perform multiple object lookups and then choose 

Export. All of your searches for that session will be exported into one xm

If you wish to clear the buffer memory of search histories, simply choose File > Clear History. Or exit AD Query.  

l file.  
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 for a computer object is as follows: "C:\Program File\SysOp Tools\ADQuery.exe" adquery C 

ou can use this syntax in any batch file or script to automate searches. Note that [C] or [U] are case sensitive. 

Example Search: "C:\Program File\SysOp Tools\ADQuery.exe" adquery U jhardy 

 

3.2 - Use with Password Reminder PRO  

Performing a User Object Search from the Report Console 

Open the Report Console. On the left of all view tab screens there is a column of gray square boxes. Double-click 

the gray box on the user data row that you would like to search. The user object opens automatically in AD query 

and displays the data. 

 

Note- This feature requires at least version 1.4.2943 of Password Reminder PRO and at least version 1.3.2875.44 

of AD Query to be installed on the same compute

3.3 - Running AD Query Searches from a Command Prompt or Script  

Performing a User or Computer Object Search from a Command Prompt or Script 
Open a command prompt. Navigate to the directory where the adquery.exe executable is located. 

 

Search syntax for a user object is as follows: "C:\Program File\SysOp Tools\ADQuery.exe" adquery U [nt acct 

name] 

Search syntax

[netbios name or CN] 

Y
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4.0 - Troubleshooting 

4.1 - Common Issues  

AD Query Does Not Return any Results "Object not found": 

(a) Make sure you have specified the correct search domain, and the domain specified is licensed for use with the 

software  

(b) Make sure the computer that you are running AD Query on has network connectivity to your Domain 

Controllers  

(c) AD Query runs under the credential set of the logged on user. Make sure your logged on account has read 

permissions to your LDAP and Active Directory and local admin permissions on the computer running AD Query  

(d) Ensure you have specified the correct SAMAccountName nam

name only and does not use matching for wildcards or partial names.  

(e) If querying a user object, make sure you have selected 'User' from the search type drop down menu 

(f) If you receive this error or the error "A compatible version of AD query Not Found" from within the Report 

Console in Password Reminder PRO, make sure y

a

 

e of the object, AD Query searches by exact 

ou have installed the latest releases as of 1/22/2008 of AD Query 

nd Password Reminder PRO from our website.  

AD Query Does Not Run or returns error "Search Domain Must End with Root Domain":  

(a) Make sure you have pasted the complete /

license key please see the next topic below.  

(b) Make sure you are running AD Query in the same LDAP domain that you specified when you registered on the 

site to download the software. Your license key is tied to the LDAP domain and will only function in this root 

domain or sub-domains of the root domain. For examp

Query in bar.com, your key created for foo.com will not work.  

(c) Make sure that .NET Framework v1.1 and all curre

F

 

If you are experiencing 

 correct license key in the program. If you need to change / edit the 

le, if you create a key for foo.com but have installed AD 

nt service packs are installed. AD Query runs on .NET 

ramework 1.1 which is NOT the same as 1.0 or 2.0  

other issues not covered, or need additional assistance please contact SysOp tech support 

via the About Us page. 

I Incorrectly Entered my License Key, or Need to Use a Key For a Different Domain- How do I Change it?  

Should it become necessary to enter a different license key in AD Query, please use the following method. 

Log in to your account on the SysOp Tools website. Create 

Open AD Query > File > Register and paste the new key.  

If you wis

the required key for the root domain (domain.com).  

h to query a child of the root domain, click Search > Change Domain and type the FQDN of your child 

domain.  

 

 

 

4.2 - Screenshots  

AD Query User Object Data: All AD Schema and LDAP attributes that exist for this object will be shown  



AD Query Computer Object Data: All AD Schema and LDAP attributes that exist for this object will be shown 
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